Задание 5. Составьте программу подсчета количества часов, минут и секунд в данном числе суток. Число суток введите с клавиатуры.​

masynchic masynchic    3   22.12.2020 20:30    12

Ответы
kkksun kkksun  21.01.2021 20:30

Неправильно считает секунды, в чём ошибка?

var

s,m,h,days: integer;

begin

writeln('Введите кол-во дней');

read(days);

s:=86400;

m:=s div 60;

h:=m div 60;

for var i:=1 to days do

s:=s*days;

m:=m*days;

h:=h*days;

writeln(s,' — секунд в ',days,' днях');

writeln(m,' — минут в ',days,' днях');

writeln(h,' — часов в ',days,' днях');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика