Задание 1.
Приведите общую характеристику языка Паскаль. Какова структура программы на Паскале.

Задание 2. Приложена картинка.
Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в ЭВМ, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y.

Задание 3.
Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X = (0,3; 5; 69; –3; 52; –20; –9; –23; –9; 10; 36; 12; 15; 23; –0,2; –36; –0,3; 8; 45; –7) при b = –6 Вычислить произведение и количество элементов, не равных нулю и больших b.

Задание 4.
Составить программу и блок-схему алгоритма для вычисления площади 5 квадратов со сторонами, изменяющимися от 0 до 15 в цикле.
В отчет включить текст программ на Паскале, реакции ЭВМ.

BoGdAn548965 BoGdAn548965    2   01.03.2020 19:09    8

Ответы
RitaSolinoviskay234 RitaSolinoviskay234  12.08.2020 01:58

№4

Объяснение:

Var x: array [1..15] of integer; p,s: real; i: integer;

begin

 s:=0; p:=1;

 x[1]:=0;  

 x[2]:=5;

 x[3]:=3;

 x[4]:=7;

 x[5]:=14;

 for i:=1 to 15 do begin

   x[i]:=i;

   Writeln('Площадь ',i,sqr(x[i]));

    end;  

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика