Задан одномерный числовой массив.напишите программу которая находит второй по величене после максимльного элемент и его номер . решение паскаль

egoraga142 egoraga142    2   09.09.2019 19:00    1

Ответы
1234567891248 1234567891248  07.10.2020 03:47
// PascalABC.NET 3.3, сборка 1562 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var s:=a.Distinct.OrderBy(x->x).Reverse.Skip(1);
  if s.Count>0 then begin
    var i:=a.FindIndex(t->t=s.First);
    Writeln('Искомый элемент равен ',a[i],' его порядковый номер ',i+1)
    end
  else Writeln('Нет искомых элементов')
end.

Пример
n= 13
-7 -2 -32 9 21 -31 34 -34 27 -35 11 7 -10
Искомый элемент равен 27 его порядковый номер 9
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика