tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Задан массив а (10). вставить
Задан массив а (10). вставить число х в массив целых чисел после всех нечетных элементов.
gramma116
1 04.06.2019 12:20
5
Ответы
irina956
05.07.2020 13:01
Var a:array[1..11] of integer;
i,t,x:integer;
begin
t:=0;
for i:=1 to 10 do begin
read(a[i]);
if odd(a[i]) then t:=i;
end;
readln(x);
for i:=11 downto t+1 do
if i>=2 then a[i]:=a[i-1];
a[t+1]:=x;
for i:=1 to 11 do
write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Noora2017
24.12.2020 15:50
Задача: Дан двумерный массив целых чисел. Вывести все строки, в которых есть трёхзначные натуральные числа. Формат ввода: На первой строке, заданы два натуральных числа, не...
JuLIaNNa2747
22.05.2020 13:27
1. Информационные технологии представляют собойа) средства поиска, сбора, обработки и использования инфор-мации;6) методы поиска, сбора, обработки и использования инфор-мации:в)...
Jastmine42
22.05.2020 13:28
Определи значения переменной после выполнения фрагмента алгоритма....
969696ааа
09.06.2019 10:10
Сформировать с датчика случайных чисел массива a[1..3,1..6], элементы которого находятся в промежутке от -60 до 60. найти сумму элементов массива. вывести на экран массив...
Ссика
09.06.2019 10:10
Жираф пробегает за 23 с 335.8м а заяц за 55 с 918.5м, кому вы вы присвоете звание чемпиона? сопостовляя их скорости (паскаль)...
choika64
09.06.2019 10:10
Написать программу в ! указание: заполнить двумерный числовой массив и(8,8) случайными целыми числами в интервале [-60,60].написать единую программу для всех ,ответ каждой...
шынар16
09.06.2019 10:10
Водномерном массиве произвольных чисел найти количество нечётных элементов(паскаль)...
shubina021
30.07.2020 11:22
26)Константа null определена в залоговочном файле: A)include.h B)stdio.h C)alloc.h D)stdlib.h 27)Инициализация данных в с++ представляет собой: A)поиск данных переменной B)проверка...
Сач16
31.07.2020 11:31
Как пройти 6задание в практикуне. Нужна написать на языке Python у вас 8 новых сообщений. ...
lednevairina
31.07.2020 08:13
Как менять направление курсора на мышке...
Популярные вопросы
В треугольнике АВС: А (1; 8); В (2; 1); С (-2; 5) 1 - определить вид треугольника...
1
решить это многочлены... Уже почии решила , а дальше не как...
2
Виписати цитати из твору Федько - Халамидник які характеризують Толіка...
1
Эпітэты,метафары,параунанні з тэксту “Уцякала зіма ад вясны”...
2
Определите силу тяжести, действующую на тело массой 500 г, если тело находится...
2
Поради підлітку із заниженою самооцінкою...
2
Тамара и Лариса совершили покупки. В первом магазине Тамара потратила часть...
1
9 класс с физикой. Тело массой 2кг движется по закону х=20-8t+4t. найти...
3
Нарисуйте рисунок, со всеми обозначениями Строение бактериальной клетки...
1
я вас умоляю, решите хоть что-нибудь из этого, если у вас супер мозг, то...
1
i,t,x:integer;
begin
t:=0;
for i:=1 to 10 do begin
read(a[i]);
if odd(a[i]) then t:=i;
end;
readln(x);
for i:=11 downto t+1 do
if i>=2 then a[i]:=a[i-1];
a[t+1]:=x;
for i:=1 to 11 do
write(a[i],' ');
end.