tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Задан массив a[1..17].
Задан массив a[1..17]. составьте программу, которая выводит индексы тех элементов, значения которых равны нулю.
karakushan
2 16.09.2019 18:30
1
Ответы
milk051
07.10.2020 20:23
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(17,-5,5); a.Println;
var s:=a.IndexesOf(t->t=0);
if s.Count>0 then s.Select(t->t+1).Println
else Writeln('нет нулей')
end.
Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
ПОКАЗАТЬ ОТВЕТЫ
VaBaGaBa
07.10.2020 20:23
Var
a:array[1..17] of integer;
i:integer;
begin
for i:= 1 to 17 do
begin
read(a[i]);
if a[i] = 0 then
Write(i, ' ');
end;
end.
пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
OOAAAOO
03.07.2019 22:20
1)дан текст из 400 символов. известно, что символы берутся из таблицы размером 32х2, в котором все ячейки заполнены разными символами. определите информационный объем...
Justacookie2003
03.07.2019 22:20
Косворд по теме устройство комьпьютора...
katya8787871
21.05.2021 09:33
Вот сама программа:var Ves, Sum, K:integer; BeginRandomize;Sum:=0 ; K:=0;Repeat Ves:=Random(7)+2;If Sum+Ves*15 =1000 then beginWriteln( Арбуз весом , Ves, кг, стоимость-...
Cказочник
18.09.2019 03:30
Укажите минимальный объем памяти необходимый для хранения изображения размером 10х20 пикселей если используется палитра из 64 цветоb...
Lansiksgo
04.05.2021 10:51
Опишите этапы рисования призмы...
samwwww
29.05.2019 19:00
Яку силу треба прикласти, щоб підняти під водою камінь вагою 3000 н, об єм якого 0, 015 м.куб.?...
vdovitskaya88
29.05.2019 19:00
Визначте масу кальцiй карбонату яку можна одержати з кальцiй оксиду масою 5.6 г та карбон дiоксиду масою 4.4 г...
рысь32
29.05.2019 19:00
Объясните,почему повторное переливание резус-положительной крови резус-отрицательной реципиенту может вызвать у него тяжелое шоковое состояние...
jogangaj
29.05.2019 19:00
Тургнев муму сочинение на тему враги и друзья герасима...
ак2005
29.05.2019 19:00
Шарик подвешенный на нити длиной l=1 метр отклоняют на угол a=60 градусов и отпускают. какой будет максимальная скорость шарика...
Популярные вопросы
Задание 2 Класс, классный, одноклассник,Пятиклассник; чувствовать„почувствовать,...
1
Task 1. Write the words in English and make the sentences as in the...
2
У атома серы энергетических уровня электронов на наружном слое ....
3
Выполните сложение векторов...
2
Тело , двигаясь неравномерно за 2 мин 60 м . Чему равна его средняя...
2
сделать по казахскому решите...
2
Объясните, как вы понимаете фразу: В отличие от животных, имеющих...
2
Какие политические режимы были у Великобритании, Франции, Италии,...
3
Задача №2. Мотоцикл проехал 200 км. Половинувсего времени движения...
1
Співала б риба коли голос був...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(17,-5,5); a.Println;
var s:=a.IndexesOf(t->t=0);
if s.Count>0 then s.Select(t->t+1).Println
else Writeln('нет нулей')
end.
Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
a:array[1..17] of integer;
i:integer;
begin
for i:= 1 to 17 do
begin
read(a[i]);
if a[i] = 0 then
Write(i, ' ');
end;
end.
пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11