Задан двумерный целочисленный массив в из n строк и m столбцов (1 ≤ n, m ≤ 10). составить программу, которая организует двумерный массив, элементы главной диагонали которого равны соответствующим элементам исходного массива, а остальные элементы равны нулю.

Muhammadkhodja Muhammadkhodja    2   06.10.2019 14:20    21

Ответы
Лена467744 Лена467744  09.10.2020 23:43

const n=6; m=n;

var b:array[1..n,1..m] of integer;

i,j: integer;

begin

writeln('Исходный массив:');

for i:=1 to n do

begin

for j:=1 to m do

 begin

 b[i,j]:=random(90)+10;

 write(b[i,j]:4);

 end;

writeln;

end;

writeln('Полученный массив:');

for i:=1 to n do

for j:=1 to m do

 if i<>j then b[i,j]:=0;

for i:=1 to n do

begin

for j:=1 to m do write(b[i,j]:4);

writeln;

end;

end.

Пример:

Исходный массив:

 59  63  74  85  64  87

 59  86  48  66  68  44

 49  36  90  15  96  34

 44  52  81  83  57  53

 61  45  93  85  16  40

 17  68  11  43  84  96

Полученный массив:

 59   0   0   0   0   0

  0  86   0   0   0   0

  0   0  90   0   0   0

  0   0   0  83   0   0

  0   0   0   0  16   0

  0   0   0   0   0  96

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика