задачка по информатике. Операторы циклов Написать программу для вычисления заданного выражения и вывода на экран полученного значения, используя заданный циклический оператор.
Выражение: 0,8 - 0,10 + 0,12 -...- 0,26
оператор цикла: while

сакура23 сакура23    3   13.02.2022 11:41    13

Ответы
sofiahayda sofiahayda  13.02.2022 11:50

numb = 8

step = 2

pred = 26

da = float('0.'+str(numb))

opr = False

while numb < pred:

   numb += step

   if opr:

       da += float('0.'+str(numb))

   else:

       da -= float('0.'+str(numb))

   opr = not opr

print(round(da,5))

Если есть вопросы - пиши

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика