Задачи по паскалю , ) 1.Стороны одного прямоугольник равны А и В (вводить
пользователь с клавиатуры). Стороны другого равны С и D
(Вводить пользователь с клавиатуры). Разработайте программу, которая
проверяет прямоугольник на Равенство их площадей. соответствующее
СООБЩЕНИЕ виведить на экран.
2.
В супермаркете объявили акцию. Покупатель, который приобретет за три
покупки товар на сумму, превышающую 1000 грн., получает
дисконтную карту при условии, что стоимость каждой последующей покупки
превышает суммарную стоимость предыдущих.
Составьте программу, которая по стоимости трех покупок определяет,
получит покупатель дисконтную карту и выводит соответствующее
сообщение на экран
3.Даны длины отрезков AB, CD I MN (вводятся с клавиатуры).
Разработайте программу, которая проверяет, могут ли эти три отрезка быть
сторонами треугольника. Соответствующее сообщение выведите на
экран.
4.Дано сторону одного квадрата и площадь другого квадрата
(Вводятся с клавиатуры). Разработайте программу, которая проверяет,
уровне эти квадраты. Соответствующее сообщение выведите на экран.

sashadorosh1953 sashadorosh1953    3   05.12.2020 13:03    4

Ответы
дашасалищева дашасалищева  04.01.2021 13:07

#1:

begin

 var a,b,c,d:real;

 write('Введите стороны A B прямоугольника: '); readln(A,B);

 write('Введите стороны C D прямоугольника: '); readln(C,D);

 write('Площади прямоугольников ',(A*B = C*D)? 'равны':'не равны');

end.

#2:

begin

 var a,b,c:real;

 write('Введите стоимость трёх покупок: '); readln(A,B,C);

 write('Дисконтная карта ', ((B>A) and (C>A+B))? 'получена':'не получена');

end.

#3:

begin

 var AB,CD,MN: real;

 write('Введите длину отрезков AB,CD,MN: '); readln(AB,CD,MN);

 write('Отрезки ',(((AB+CD)>MN) and ((AB+MN)>CD) and ((CD+MN)>AB))? 'могут':'не могут', ' быть сторонами треугольника');

end.

#4:

begin

 var A,B:real;

 write('Введите сторону первого квадрата: '); readln(A);

 write('Введите площадь второго квадрата: '); readln(B);

 write('Площади заданных квадратов ', (A.Sqr=B)? 'равны':'не равны');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика