Задача No3
Составить программу разложения натурального числа n на множители.
пример: 360 = 2 2 2 3 3 5. Посчитать количество разных множителей.
our
python цикл while​

wwwvadimsokol wwwvadimsokol    1   15.03.2020 03:13    13

Ответы
ludmillychka ludmillychka  11.10.2020 21:48

n = int(input())

divisor = 2

unique = set()

while n > 1:

   if n % divisor == 0:

       print(divisor, end=' ')

       unique.add(divisor)

       n //= divisor

   else:

       divisor += 1

print('\nКоличество уникальных делителей: {0}'.format(len(unique)))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика