Задача для Python по теме множества
Напишите программу, которая находит все различные цифры в символьной строке.
Входные данные
На вход программе подаётся символьная строка.
ыходные данные
Программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. Если в строке нет цифр, нужно вывести слово 'NO'.

аня2931 аня2931    2   19.03.2020 06:42    120

Ответы
OakCadet OakCadet  12.10.2020 01:07

string = input().split()

number_list = []

for elem in string:

   if elem.isdigit() == True:

       number_list.append(elem)

number_list.sort()

if len(number_list) == 0:

   print('NO')

else:

   print(number_list)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика