Задача №70. Переставить соседние элементы Напишите программу, которая переставляет соседние элементы массива (1-й элемент поменять с 2-м, 3-й с 4-м и т.д. Если элементов нечетное число, то последний элемент остается на своем месте).

Входные данные
Сначала задано число N — количество элементов в массиве (1≤N≤35). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.

Выходные данные
Необходимо вывести массив, полученный после перестановки элементов.

Солі Солі    3   30.12.2021 15:38    7

Ответы
ccallul ccallul  30.12.2021 15:40

проф:

N = input()

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(a)

или мое лоховское:

N= input()

s = []

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   s.append(a[i])

   s.append(a[i-1])

if len(a) % 2 != 0:

   s.append(a[-1])

print(s)

Объяснение:

N нигде не используется

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика