Задача №6 на пайтоне
Напишите программу, которая запрашивает двузначные числа A и B (A<=B) и определяет, есть ли в диапазоне чисел от A до B включительно такие, что сумма цифр равна 10. Если таких чисел нет - выведите "NO", а если есть выведите - "YES".

Sample Input 1:

10 18
Sample Output 1:

NO
Sample Input 2:

10 20
Sample Output 2:

YES

Oueio Oueio    3   14.03.2021 20:59    32

Ответы
ankadudka ankadudka  13.04.2021 20:59

a = int(input('Введите a: '))

while True:

 b = int(input('Введите b (b>a): '))

 if b>a: break

 print('b должно быть больше a!')

check = False

for i in range(a,b+1):

 j = i

 s = 0

 while j > 0:

   s += j%10

   j = j//10

 if s == 10:

   check = True

   break

print('YES' if check else 'NO')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика