Задача 126: Кубическое уравнениеНапишите программу, которая будет искать все целые x, удовлетворяющие уравнению:Ax3 + Bx2 + Cx + D = 0, где A, B, C, D — заданные целые числа.Формат входных данных. Во входном файле записаны четыре целых числа: A, B, C, D. Всечисла по модулю не превышают 2*109 .Формат выходных данных. В выходной файл выведите сначала количество решений этогоуравнения в целых числах, а затем сами корни в порядке возрастания. Если уравнение имеетбесконечно много корней, выведите в выходной файл одно число -1 Методом ооп решить надо, обычным я понимаю как решать, но оопшным не понимаю:)

peskovaedoz45yo peskovaedoz45yo    2   10.06.2021 23:01    1

Ответы
ilyagnomm ilyagnomm  10.07.2021 23:02

a, b, c, d = map(int, input().split())

c = 0

A = []

if a + b + c + d > 0:

   print(0)

else:

   for x in range(-100000, 1000000 + 1):

       if a * x ** 3 + b * x**2 + c * x + d == 0:

           c += 1

           A.append(x)

           if c > 30:

               break

   if c > 30:

       print(-1)

   else:

       print(c)

       for i in range(len(A)):

           print(A[i])

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика