Задача №1 Выполнить трассировку (прогон) программы и определить, что будет выведено на экран после выполнения фрагмента программы. ( )

……

Begin

А:=1;

For С:=10 downto 5 do

Begin

A:=A+C;

End;

Writeln (‘Значение A=’, A);

End.

Задача №2 Выполнить трассировку (прогон) программы и определить, чему будет равно значение переменной b после выполнения фрагмента программы. ( )

……

Begin

b:=0;

For k:=2 to 3 do

Begin

For i:=1 to 2 do

b:=b+2*i*k;

End;

End;

b:=sqr (b);

Writeln (‘b=’, b);

End.

Задача №3 Выполнить трассировку (прогон) программы и определить, чему будет равно значение переменной X и S после выполнения фрагмента программы. ( )

……

Begin

S:=0; X:=10; A:=0; B:=0;

For i:=1 to 3 do

Begin

S:=S+2*i;

if X>=6 then X:=X / 2

else X:=X*6;

End;

if S
S:=Dec (S);

X:=Inc(X);

End;

Writeln (‘X=’, X);

Writeln (‘S=’, S);

End.

hussrav98 hussrav98    1   23.04.2020 14:21    6

Другие вопросы по теме Информатика