Задача 1. Создать программу для формирования таблицы умножения (таблицы Пифагора).
Program Piphagor;
Uses crt;
var i,j:byte;
a: array [1..9, 1..9] of integer;
begin
clrscr;
{шапка таблицы Пифагора}
for i:=1 to 9 do write(i:3,' |'); writeln;
for i:=1 to 9 do write('+'); writeln;
{сама таблица}
for i:=2 to 9 do
begin
for j:=1 to 9 do
begin
a[i,j]:=i*j;
write(a[i,j]:3,' |');
end;
writeln;
end;
readln;
end.

Пример № 2.
Составить программу, которая в двумерном массиве случайных чисел находит в каждой строке наибольший элемент и записывает его в одномерный массив.
m – количество строк в двумерном массиве и длина одномерного массива;
n – количество столбцов;
A[1..m,1..n] - двумерный массив;
B[1..m] – одномерный массив
max – вс переменная для нахождения наибольшего элемента в каждой строке.

Program max_str;
Uses crt;
сonst
m=5;
n=6;
var i,j:byte;
a: array [1..m, 1..n] of integer;
b: array [1..m] of integer;
max: integer;
begin
clrscr;randomize;
for i:=1 to m do
begin
for j:=1 to n do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
writeln;
end;
writeln ('Массив из максимальных значений в строках:');
for i:=1 to m do
begin
max:=a[i,1];
for j:=2 to n do
begin
if a[i,j]>max then max:=a[i,j];
end;
b[i]:=max;
write (b[i]:4);
end;
readln;
end.

ekaterinakostin ekaterinakostin    1   14.05.2020 00:21    8

Другие вопросы по теме Информатика