Задача 1. Составить программу для вычисления произведения N чисел.

Задача 2. Дано целое число n. Вычислить значение факториала n!
Теория: Рассмотрим, чему равняется 3! (факториал): P=3*2*1=6
Еще один пример: 5!: Р=5*4*3*2*1=120

svetlanagilman1 svetlanagilman1    1   20.04.2020 06:39    1

Ответы
baten baten  13.10.2020 12:07

1)var n,i,sum: integer;

a: array [1..1000] of integer;

begin

writeln('Введите кол-во чисел N: ');

read(n);

sum:=1;

for I:= 1 to n do  

sum:=sum*i;

write('Произведение всех чисел = ',sum);

end.

2)var

 n, i, s: integer;

begin

 read(n);

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln(s);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика