Задача 1. Напишите программу, которая в последовательности натуральных чисел определяет сумму двузначных чисел, оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму двузначных чисел, оканчивающихся на 5.

Задача 2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 2 и среднее значение суммы таких чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести два числа — количество чисел, оканчивающихся на 2 и среднее значение суммы таких чисел. Если таких чисел нет, то программа должна вывести «No».

chepelenkosivun chepelenkosivun    2   22.04.2020 20:21    24

Ответы
Vil67 Vil67  22.04.2020 20:30

var n,i,a,s: integer;

begin

write('Введите количество чисел в последовательности: ');

readln(n);

for i := 1 to n do

begin

write('Введите число: ');

readln(a);

if a mod 3 = 0 then s:=s+a;

end;

writeln('Сумма чисел, кратных 3, равна: ',s)

end.

Вторая задача

var

i,n:1..100;

a:-300..300;

s:-30000..30000;

begin

s:=0;

read(n);

for i:=1 to n do begin

read(a)

if a mod 10=3 then s:=s+a;

end;

write(s);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика