Язык Python3 Простое число
По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число.

Входные данные

Во входном файле находится одно натуральное число K.

Выходные данные

В выходной файл выведите K-е простое число.

Примеры

Ввод:
3
Вывод:
5
Ввод:
1
Вывод:
2

jansayabektasova jansayabektasova    2   14.06.2020 20:47    14

Ответы
ismaildior200920 ismaildior200920  15.10.2020 14:00

Ну, можно так:

Объяснение:

def prostoe(chislo):

   a = True

   for i in range(2, chislo//2 + 1):

       if chislo % i == 0:

           a = False

           break

   return a

k = int(input("Введите число, не превосходящие 100000: "))

schetchic = 1

a = 2

while k >= schetchic:

   if prostoe(a):

       prostoi = a

       schetchic += 1

   a += 1

print(prostoi)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика