Язык - Python
Развернуть элементы с нечетными индексами
Вам дан список целых чисел. Разверните элементы с нечетными индексами.
Входные данные
Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке.
Выходные данные
Выведите получившийся список.
Примеры
Ввод
1 2 3 4 5
Вывод
1 4 3 2 5

Chehows Chehows    1   24.06.2020 21:47    94

Ответы
nurpaik nurpaik  15.10.2020 14:49

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика