Язык Python. Напишите программу, которая будет выводить, какую по счёту дощечку прибили.

Формат ввода
Сначала вводится число – сколько нужно дощечек.
Затем вводятся строки, пока не будет введена строка КОНЕЦ

Формат вывода
Строки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:
Прибили {номер} дощечку.

Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:
ГОТОВО

Если не хватило, то вывести в конце:
МАЛОВАТО​

emasihinp08dbq emasihinp08dbq    1   03.12.2020 18:47    18

Ответы
человек661 человек661  02.01.2021 18:53

x = int(input())

s = ''

c = 0

while s != 'КОНЕЦ':

   s = input()

   if 'доска' in s or 'дощечка' in s:

       c += 1

       print('Прибили', c, 'дощечку.')

   if c == x:

       break

if c != x:

   print('МАЛОВАТО')

else:

   print('ГОТОВО')

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика