Язык программирования си ! написать программу для работы с массивом структур . программа требует: 1. создайте шаблон структуры с полями, которые соответствуют предметной области . 2. определите тип конструкции. 3. определите размер массива из пяти элементов, каждый из которых является определенной структурой. программа должна выполнять следующие функции: 1. ввод данных структуры с клавиатуры. 2. выполнение работы с массивом конструкций в соответствии с требованиями . 3. вывод результата на экран, при необходимости, в виде таблицы. данные внутри структуры должны совпадать с темой : 1. опишите структуру с именем price, содержащее следующие поля: • наименование продукта; • наименование магазина, в котором товары; • стоимость товара . 2. напишите программу, которая выполняет следующие действия: • ввод данных с клавиатуры в массив из 5 структур типа price; • организовывать записи в алфавитном порядке по названиям магазинов; • вывод информации о товарах, продаваемых в магазине, который был введен с клавиатуры; если элементов нет, отобразите соответствующее сообщение на экране.

Arina111933 Arina111933    1   01.04.2019 16:02    1

Ответы
AnektodaNet AnektodaNet  28.05.2020 06:48

Сортировал массив пузырьком (сравнивал первый символ в названии магазина).

Пробегался циклом через массив и функцией strcmp, сравнивал названия магазинов и строку с названием того магазина, который мы ищем.

Если вкратце, strcmp возвращает нам -1 когда строка которая передаётся в качестве первого параметра больше, 0 когда они равны (по содержимому тоже), и 1 если строка которая передаётся 2 параметром больше.

Вот мой вариант:

#include <stdio.h>

#include <string.h>

#include <ctype.h>

#include <windows.h>

template <typename T>

struct PRICE

{

   char prod_name[20];

   char shop_name[20];

   T price;

};

template <typename T>

void sortByShop(PRICE<T>* arr, int size)

{

   PRICE<T> tmp;

   bool check=true;

   while(check)

   {

       check=false;

       for(int i=0; i < size-1; ++i)

       {

           if(toupper(arr[i].shop_name[0])>toupper(arr[i+1].shop_name[0]))

           {

               tmp = arr[i];

               arr[i]=arr[i+1];

               arr[i+1]=tmp;

               check=true;

           }

       }

   }

}

template <typename T>

void show(PRICE<T>* arr, int size)

{

   for(int i = 0; i < size; ++i)

   {

       printf("\nshop name -> %s\n",arr[i].shop_name);

       printf("poduct name -> %s\n",arr[i].prod_name);

       printf("poduct price -> %d\n",arr[i].price);

   }

}

int main()

{

   const int size = 5;

   PRICE<double> arr[size];

   for(int i = 0; i < size; ++i)

   {

       printf("Enter shop name -> ");

       scanf("%s",&arr[i].shop_name);

       printf("Enter poduct name -> ");

       scanf("%s",&arr[i].prod_name);

       printf("Enter poduct price -> ");

       scanf("%d",&arr[i].price);

   }

   show(arr,size);

   sortByShop(arr,size);

   printf("\nSorted array.\n");

   show(arr,size);

   char target[20];

   printf("Enter shop name -> ");

   scanf("%s",&target);

   bool check=false;

   for(int i = 0; i < size; ++i)

   {

       if(strcmp(arr[i].shop_name,target)==0)

       {

           printf("\nFounded products:\n");

           printf("poduct name -> %s\n",arr[i].prod_name);

           check=true;

       }

   }

   if(!check) printf("Shop is not founded.\n");

   system("pause");

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика