tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Язык программирования с# написать
Язык программирования с# написать программу решения квадратного уравнения ax^2+bx+c=0 для 3 случаев, когда: 1)d> 0 2d=0 3)d< 0
академег228
3 10.09.2019 05:30
2
Ответы
kolesya2
10.08.2020 17:23
Using System;
public class Test
{
public static void Main()
{
double a,b,c,D;
Console.WriteLine("программа для решения квадратного уравнения вида ax^2+bx+c=0");
Console.Write("введите a: a=");
a=double.Parse(Console.ReadLine());
Console.Write("введите b: b=");
b=double.Parse(Console.ReadLine());
Console.Write("введите c: c=");
c=double.Parse(Console.ReadLine());
Console.WriteLine("решаем уравнение:");
Console.WriteLine(a+"*x^2+("+b+")*x+("+c+")=0");
D=b*b-4*a*c;
Console.WriteLine("D="+b*b+"-"+"("+4*a*c+")="+D);
if (D<0){ Console.Write("D<0 => нет действительных корней");} else if (D>0)
{
Console.WriteLine("D>0 => уравнение имеет 2 действительных корня");
Console.WriteLine("x1="+(-b+Math.Sqrt(D))/(2*a));
Console.WriteLine("x2="+(-b-Math.Sqrt(D))/(2*a));
} else{
Console.WriteLine("D=0 => уравнение имеет 2 совпадающих корня");
Console.WriteLine("x1=x2="+(-b/(2*a)));
}
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Nurs147
15.12.2021 11:41
до 15:00 нудно сделать всего 3 вопроса...
listova
22.01.2021 13:14
Питон y=x^2 значение функции x=1 2 3 4 5 6 7 8 9 10 помагите...
мумуму13
22.01.2021 13:13
Напишите эссе на тему: Для чего мы изучаем программирование (50-80 слов)...
egorviktorov20
22.01.2021 13:13
Обчисліть довжину двійкового коду текстуКнижка містить 37 сторінок, на кожній сторінці 70 рядків, у кожному рядку 55 символів(включаючи пропуски). Знайдіть довжину двійкового...
valeriacom11
22.01.2021 13:12
Для тех кто не знает ник belkaoflkal321 ...
VikaNika16
30.04.2020 21:18
Рішення вправи 3 сторінка 175 підручник Морзе, Барна, Вембер для 8 класу...
amina318
28.07.2019 08:30
17 в шестнадцатеричной перевести в восмеричную...
Kurbatovaolga15
05.10.2019 02:20
Какова будет последовательность записей, если в таблице базы данных поле видспорта данные будут отсортированы в порядке возрастания? код фамилия датарождения видспорта 1 маммедли...
yanalitvinova
05.10.2019 02:20
222222222222222222222222222222222222222222222222...
rustie
06.07.2019 22:40
Диалог по на тему о выборе своей будущей профессии...
Популярные вопросы
Найти количество решений уравнения в зависимости от параметра р a) | x^2...
3
достаточно доказать что 1.OR=XY 2.PR=XY 3.нет ответа 4.PR=AX...
2
Решите задачу с пояснением...
3
Аналогічно виконайте п. 2, але вже використовуючи оператор or....
3
Как пользоваться командой /tban в Майнкрафт...
3
Напишиье жаргона и 2 диалекта...
2
Родственные тональности CIS MOLL...
3
Приведите пример узбекской росписи нужно!...
1
Скажите просто ответы ( представь одночлены в стандартном виде.)...
1
1Какой из перечисленных ниже процессов к механическим колебаниям: а) сезонные...
3
public class Test
{
public static void Main()
{
double a,b,c,D;
Console.WriteLine("программа для решения квадратного уравнения вида ax^2+bx+c=0");
Console.Write("введите a: a=");
a=double.Parse(Console.ReadLine());
Console.Write("введите b: b=");
b=double.Parse(Console.ReadLine());
Console.Write("введите c: c=");
c=double.Parse(Console.ReadLine());
Console.WriteLine("решаем уравнение:");
Console.WriteLine(a+"*x^2+("+b+")*x+("+c+")=0");
D=b*b-4*a*c;
Console.WriteLine("D="+b*b+"-"+"("+4*a*c+")="+D);
if (D<0){ Console.Write("D<0 => нет действительных корней");} else if (D>0)
{
Console.WriteLine("D>0 => уравнение имеет 2 действительных корня");
Console.WriteLine("x1="+(-b+Math.Sqrt(D))/(2*a));
Console.WriteLine("x2="+(-b-Math.Sqrt(D))/(2*a));
} else{
Console.WriteLine("D=0 => уравнение имеет 2 совпадающих корня");
Console.WriteLine("x1=x2="+(-b/(2*a)));
}
}
}