Язык программирования - Python.

Имеется неограниченное количество монет в 1, 2, 5, 10 рублей. Определите, сколькими можно выдать сдачу в n рублей. Например, 5 рублей можно выдать четырьмя : 5=2+2+1=2+1+1+1=1+1+1+1+1.

Входные данные
Программа получает на вход натуральное число n, не превышающее 106.

Выходные данные
Выведите ответ на задачу. Примечание Правильное решение задачи можно написать, используя всего один цикл while. Примеры
Ввод
2
100000
Вывод
2
1667116705001

Olgadaleewa Olgadaleewa    2   12.03.2021 22:17    17

Ответы
marceries marceries  12.03.2021 22:20

s=int(input())

ans = 0

s5=0

while s5<=s:

    s1=s-s5

    ans+=(s1//2+1)*(s5//10+1)

    s5+=5

print(ans)

ПОКАЗАТЬ ОТВЕТЫ
280artur280 280artur280  12.03.2021 22:20

--- Python 3.8.3 ---

n = int(input('n: \n'))

counter = 0

for coin1 in range(0, n+ 1):

  for coin2 in range(0, (n // 2) + 1):

      for coin5 in range(0, (n // 5) + 1):

          for coin10 in range(0, (n // 10) + 1):

              if coin1 * 1 + coin2 * 2 + coin5 * 5 + coin10 * 10 == n: counter += 1

print(counter)

для n в пределах 100-200 считает вроде правильно, и достаточно быстро. Что до больших значений n, мне не хватило терпения. Ненормально это, успеть попить чаю в ожидании конца работы программы в 8 строк.

При желании можно использовать как стресс-тест ЦПУ

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика