Язык программирования: паскаль. написать программу. заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.

khorolovgusenoy2lzx khorolovgusenoy2lzx    1   19.03.2019 05:10    31

Ответы
sergey260 sergey260  07.06.2020 03:42

var a:array[1..10]of integer;
i,j,k:integer;
begin
for i:=1 to 10 do a[i]:=random(101);
for i:=1 to 10 do write(a[i],' ');
writeln;


for i:=1 to 5 do
for j:=1 to 4 do
if a[j]>a[j+1] then begin
k:=a[j];
a[j]:=a[j+1];
a[j+1]:=k;
end;

 

for i:=1 to 5 do
for j:=7 to 10 do
if a[j]>a[j-1] then begin
k:=a[j];
a[j]:=a[j-1];
a[j-1]:=k;
end;

 

for i:=1 to 10 do write(a[i],' ');


end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика