Язык программирования: C или C++. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.

charlie911 charlie911    3   28.12.2020 13:15    9

Ответы
АлинаМалинка116 АлинаМалинка116  27.01.2021 13:16

#include <iostream>

#include <vector>

#include <cstdlib>

#include <ctime>

#include <algorithm>

using namespace std;

int main() {

vector<int> arr;

srand(time(0));

for (int i = 0; i < 10; ++i) {

 arr.push_back(rand() % 101);

 cout << arr[i] << " ";

}

cout << endl << "Sorted: ";

for (int j = 0; j < 100; ++j) {

 for (int i = 0; i < arr.size()-1; ++i) {

  if (i < 4) {

   if (arr[i] > arr[i + 1]) {

    swap(arr[i], arr[i + 1]);

   }

  }

  else {

   if (arr[i] < arr[i + 1]) {

    swap(arr[i], arr[i + 1]);

   }

  }

 }

}

for (int i = 0; i < 10; ++i) {

 if (i == 5) {

  cout << "/// ";

 }

 cout << arr[i] << " ";

}

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика