Язык pascalabc или python максимальные . с клавиатуры вводятся координаты (x,y) двух точек a и b (координаты могут быть отрицательными, положительными или нулевыми)нужно написать программу, которая находит расстояние от точки a до b

katau852Katau164 katau852Katau164    1   11.06.2019 00:23    2

Ответы
rystamgfţ rystamgfţ  09.07.2020 07:53

program zz1;

var x1, x2, y1, y2, d: real; //задаем переменные не целого типа

begin

write(' введите координаты точки а '); // вводим с клавиатуры координату х и координату у первой точки

read(x1, y1);  

write('введите координаты точки b '); // вводим с клавиатуры координату х и координату у второй точки

read(x2, y2);

d:=sqrt(sqr(x1 - x2) + sqr(y1 - y2));   // находим длину отрезка по формуле

write(' длина отрезка ab = ', d:5:2); // выводим ответ в формате пять знаков для числа и два знака после точки

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика