Язык borland c++ никаких паскалей написать программу,позволяющую для заданного одномерного массива а из n вещественных или целых элементов реализовать обработку массива.длина массива n задается пользователем как константное выражение.исходные данные задать вручную или с генератора случайных чисел,учитывая формат элементов массива а.тип результата определяется из контекста. -вычислить количество отрицательных элементов массива; -сумму модулей элементов массива,расположенных после максимального элемента

kamilaraeva kamilaraeva    2   17.06.2019 09:00    2

Ответы
Olenadob Olenadob  13.07.2020 23:45
#include <cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{int i,k,max,j,n,s;
srand(time(NULL)); k=0; s=0;
cout<<"Введите размерность массива:"<<endl;
cin>>n;
int a[n];
cout<<"Данный массив:"<<endl;
for (i=0;i<=n;i++) {a[i]=rand()%21-10; cout<<a[i]<<" ";}
max=a[0]; j=0;
for (i=0;i<=n;i++) {if (a[i]<0) k=k+1; if (a[i]>max) {max=a[i]; j=i;}}
cout<<"Количество отрицательных элементов - "<<k<<endl;
for (i=j+1;i<=n;i++) s+=abs(a[i]);
cout<<"Сумма модулей элементов массива, расположенных после максимального - "<<s<<endl;

    system("PAUSE");
    return EXIT_SUCCESS;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика