Y=x*cos(x)+sin(x) написать программу цикл с параметром и с предусловием pascal abc

Позитив4ик123 Позитив4ик123    3   10.08.2019 08:00    1

Ответы
milashenko005 milashenko005  04.10.2020 08:54
1)
const x0=1.0; xk=2.0; h=0.1;
var x,y:real; i:integer;
begin
x:=x0-h;
for i:=1 to round((xk-x0)/h)+1 do
 begin
 x:=x+h;
 y:=x*cos(x)+sin(x);
 writeln(x:3:1,y:7:3);
 end;
end.

2)
const x0=1.0; xk=2.0; h=0.1;
var x,y:real;
begin
x:=x0-h;
while x<xk do
 begin
 x:=x+h;
 y:=x*cos(x)+sin(x);
 writeln(x:3:1,y:7:3);
 end;
end.

Результат:
1.0  1.382
1.1  1.390
1.2  1.367
1.3  1.311
1.4  1.223
1.5  1.104
1.6  0.953
1.7  0.773
1.8  0.565
1.9  0.332
2.0  0.077
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика