tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Выручайте, написать программу
Выручайте, написать программу в паскале: " даны два целых числа: d (день) и m (месяц), определяющие правильную дату не високосного года. вывести значения d и m для даты, предшествующей указанной." используя команду case.
anastasia4571
3 29.06.2019 18:30
7
Ответы
VladSolo
23.07.2020 16:32
Program a;
var D,M: integer;
begin
readln (D,M); //DD MM
if (D<>1) then Writeln (D-1,' ',M)
else
case M of
01 : Writeln('31 12');
02 : Writeln('31 01');
03 : Writeln('28 02');
04 : Writeln('31 03');
05 : Writeln('30 04');
06 : Writeln('31 05');
07 : Writeln('30 06');
08 : Writeln('31 07');
09 : Writeln('31 08');
10 : Writeln('30 09');
11 : Writeln('31 10');
12 : Writeln('30 11');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
tkurchanova
11.05.2020 14:22
Тести з теми «Комп’ютерні публікації» 1. Що називають публікацією: а) звіт про виконання роботи б) представлення певної ідеї чи проекту в) виступ перед аудиторією...
bragi2015
11.05.2020 14:21
С) Радиусы 50 болатын, қызылтүспен толық боялған дөңгелектіэкран бетіне шығарау кодынжазыңыз решить задачу...
Станислав929
20.01.2021 15:37
1. Алгоритм деген не? 2. Программада жаңа терезе ашу үшін қандай қадамдарды орындау керек?3. Python программалау тілі деген не? 4. print функциясы кандай қызмет аткарады?...
Спирт95
20.01.2021 15:37
Задача на Python Исключающее ИЛИВсе решения задач необходимо оформлять в виде соответствующих функций. Ввод и вывод данных должны осуществляться в основной части программы....
diamond31
12.03.2021 14:58
Утристрасро ого не нужно.2.UULU DUІЛИ. OUTLEте запишите только целое число, единицу измерения писатьПІСЛутков. Искомый объём неАвтоматическая фотокамера каждые 15...
89640197456
12.03.2021 14:58
Что такое Условные операторы 3 назовите условных операторов...
Arse20
12.03.2021 14:57
С) Расставьте в нужном порядке строки и допиши недостающие элементы программы для задачи: С клавиатурывводятся две переменные Длина и Ширина прямоугольника.Необходимо...
Наполнение
12.03.2021 14:57
Python программалау тілінің интерфейсі берілген ...
zige
12.03.2021 14:57
Программирование линейных алгоритмов. Урок 3 Пзучи предложенную формулу и определи, как изменится значение переплаты, если уменьшить срок ипотеки в два раза и увеличить...
lotosalla1
16.03.2021 16:40
2. Найдите и перепишите все этапы создания лекции на этой платформе. Modlle...
Популярные вопросы
Тригонометрическое уравнение: cos п корень из x = - корень из 3/2...
2
В-две собаки. подчеркните в предложении главные и второстепенные...
2
Напишите про любое животное и про то как оно при к своей среде...
3
Народ кто читал или кто знает где, нужно сокрашение король воров...
2
Сочинить сказу на тему жили были числа...
1
Краткий фонетический разбор слова ледок...
1
Борис купил 4 книги.все книги без первой стоят 42 рубля,без второй...
2
1. выбирите вариант(ы), в котором(ых) выделенное слово верно определённо...
1
420: 6+(700-640)*5 700-(810-390): 7+6*60...
2
1/2x+1/3x=9 6-2x=3x-10 -4*(5-4x)=x+1...
3
var D,M: integer;
begin
readln (D,M); //DD MM
if (D<>1) then Writeln (D-1,' ',M)
else
case M of
01 : Writeln('31 12');
02 : Writeln('31 01');
03 : Writeln('28 02');
04 : Writeln('31 03');
05 : Writeln('30 04');
06 : Writeln('31 05');
07 : Writeln('30 06');
08 : Writeln('31 07');
09 : Writeln('31 08');
10 : Writeln('30 09');
11 : Writeln('31 10');
12 : Writeln('30 11');
end;
end.