Вводится массив, состоящий из целых чисел. определите, сколько из них положительные. входные данные сначала задано число n — количество элементов в массиве (1≤n≤35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести одно целое число — количество положительных элементов массива. примеры ввод вывод 3 1 -2 0 1

Ailina24 Ailina24    3   02.09.2019 17:50    18

Ответы
adobycina43 adobycina43  06.10.2020 12:51
Program n1;
var n, k, i, c : integer; a:array[0..35] of integer;
begin
  read(N);
  if (N>=1)and(N<=35) then c:=n
  else
    begin
      writeln('error');
      read(N);
    end;
  for i:=1 to c do
    begin
      read(a[i]);
      if A[i]>0 then k:=k+1;
    end;
  writeln(k);
end.

Как то так
программа была скопирована из компилятора и там работала по условию
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика