Ввести одномерный массив из 13 элементов. определить сумму элементов, которые при умножении на 4 значение большее чем при возведении в квадрат. напишите программу, .

арсаева арсаева    1   12.09.2019 13:30    3

Ответы
heylolitahey heylolitahey  07.10.2020 09:45
Program n1;
const n=13;
var a: array [1..n] of integer;
i,sum:integer;
begin
randomize;
sum:=0;
write('исходный массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
if a[i]*4>a[i]*a[i] then sum:=sum+a[i];
end;
writeln;
write('искомая сумма: ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
KOROTKOVAKATA KOROTKOVAKATA  07.10.2020 09:45
Const
  CSize = 13;

var
  m: array[1..CSize] of integer;
  sum: integer;

begin
  sum := 0;
  for var i := 1 to CSize do
  begin
    read(m[i]);
    if (m[i] * 4) > (sqr(m[i])) then sum := sum + m[i];
  end;
  write(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика