Ввести двузначное целое число х< 15. написать программу перевода его в восьмеричную систему счисления.(паскаль)

Gulshat51 Gulshat51    2   25.09.2019 06:00    5

Ответы
romankrohov2005 romankrohov2005  08.10.2020 17:36
Странное задание!
Если число целое и двухзначное меньше 15, то это числа 10, 11, 12, 13 и 14. В восьмеричном представлении они больше десятичного значения на 2, т.е. 10₁₀ = 12₈, 11₁₀ = 13₈, ... 14₁₀ = 16₈

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите число от 10 до 14:');
  Writeln('В восьмеричной системе оно записывается как ',n+2)
end.

Пример
Введите число от 10 до 14: 13
В восьмеричной системе оно записывается как 15
ПОКАЗАТЬ ОТВЕТЫ
lelyaklochkova lelyaklochkova  08.10.2020 17:36
Const zs='01234567'; //цифры в 8 СС
s:string;
begin
write('Введите число в 10 СС: ');
readln(n);
s:='';
while n>0 do
begin
s:=zs[n mod 8+1]+s; //берем остаток от деления на 8 и эту цифру пишем в начало строки
n:=n div 8 //сокращаем число
end;
write('Число в 8 СС: ',s);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика