tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Всоставить программу
Всоставить программу в которой значение каждого элемента массива равно раннее введённому значению минус порядковый номер
Monimix
1 17.08.2019 11:50
1
Ответы
ta2001nja
05.10.2020 00:40
// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var a:=ReadArrInteger('Вводите элементы массива:',n);
a:=a.Select((x,i)->x-i-1).ToArray; a.Println
end.
Пример
n= 7
Вводите элементы массива: -12 4 0 -7 9 18 3
-13 2 -3 -11 4 12 -4
ПОКАЗАТЬ ОТВЕТЫ
медныйвсадник
05.10.2020 00:40
program zadacha;vara: array[1..10] of integer;i,n: integer;beginfor i:=1 to 10 do read(a[i]);writeln();for i:=1 to 10 do begina[i]:=a[i]-i;write(a[i]:6);end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
зубрильчик
02.10.2019 05:30
Составить схему алгоритма и программу для вычисления значений функций y и f для заданных значений переменной x и постоянных a и b. значения переменной x =0. вывести на экран значения...
yeghiazaryanhap01lbi
02.10.2019 05:30
Встроке окончание слов ая заменить ой информатика...
DenisGaleev
02.10.2019 05:40
Мир охватила эпидемия воспаления хитрости! ученым удалось выделить днк из трех вероятно зараженных клеток. днк каждой из клеток состоит из последовательности азотистых оснований, каждое...
Brainsetup
02.10.2019 05:40
Дан массив, состоящий из 8 элементов вещественного типа. найдите произведение первых 4 элементов....
dilnaz61
02.10.2019 05:40
Придумайте собственный кодирования букв алфавита с собственного кода закодируйте свое имя...
Keonaks
14.12.2020 17:36
Запишите число 4435 в десятичной системе счисления. Запишите только само число, основание системы счисления писать не нужно....
svetskazka1978
11.03.2019 13:40
С* сканируется цветное изображение размером 10х10 см. разрешающая сканера 1200х1200 dpi, глубина цвета 24 бита. какой информационный объем будет иметь полученный графический файл?...
maksdlernerwanemaks
11.03.2019 13:40
Видеопамять имеет объем, в котором может храниться 4-цветные изображение размером 300*200. какого размера изображение может хранить в том же объеме видеопамяти, если оно будет использовать...
roapoaop
09.12.2020 15:07
Зависит ли величина наносимых размеров на чертеже от величины масштаба? ...
toktasynnazerke
09.12.2020 15:07
Развитию экономики ЦЧР благоприятствуют… А. природные условия Б. природные ресурсыВ. ЭГП...
Популярные вопросы
Решите все Отмечу как лучший ответ....
2
Із наведеного переліку позначте грецькі колонії у Північному Причорномор ї: Карфаген,...
1
11. Здійсніть перетворення:етан - етен - етин - Дихлоретен....
3
Вычислите в теради 4,2:0,21;18:0,005;62,5:0,0025;...
2
Биология 6 ксасс составить таблицу...
2
7 Есептің шешуін өрнек түрінде жаз.а) Каспий теңізіндегі итбалықтарды сақтау үшін,...
2
Речи. 1. Прочитайте текст. Подберите заголовок, отражающий его основную мысль. Определите...
2
Математика 112 страница 9упражнения...
1
Словосочетание со словами: Плакса, задира, забияка, неряха, невежа , невежда...
2
58-бет.4-тапсырма. Көксеректі жазушы қалай суреттеді.Опиши как описывает автор в...
1
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var a:=ReadArrInteger('Вводите элементы массива:',n);
a:=a.Select((x,i)->x-i-1).ToArray; a.Println
end.
Пример
n= 7
Вводите элементы массива: -12 4 0 -7 9 18 3
-13 2 -3 -11 4 12 -4