Всем, нужно написать программу не используя операторы цикла (формулой) длина московской кольцевой автомобильной дороги —109 километров. байкер вася стартует с нулевого километра мкад и едет со скоростью v километров в час. на какой отметке он остановится через t часов? входные данные программа получает на вход значения v и t. если v> 0, то вася движется в положительном направлении по мкад, если же значение v< 0, то в отрицательном. выходные данные программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится вася.

Alexandra0606 Alexandra0606    3   13.08.2019 20:30    3

Ответы
elveranasibull elveranasibull  31.08.2020 15:29
Var v,t,x:integer;
begin
write('v = ');
readln(v);
write('t = ');
readln(t);
x:=(109+(v*t-(v*t div 109)*109) mod 109) mod 109;
writeln(x);
end.

Пример 1:
v = 50
t = 3
41

Пример 2:
v = -50
t = 3
68
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика