Все свои напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе длины сторон треугольника.

koki1501 koki1501    3   16.09.2019 11:20    3

Ответы
allapogorelayaoxd0fz allapogorelayaoxd0fz  07.10.2020 19:34
Var
a, b, c: real;
begin
  Read(a, b, c);
  if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
    Writeln('Треугольник прямоугольный!')
  else
    Writeln('Треугольник непрямоугольный!')
end.

Пример:

3 4 5
Треугольник прямоугольный!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика