tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вс++ составить программу
Вс++ составить программу нахождения числа строк матрицы а(6,6), максимальный элемент которых больше р
F1Na1Ik
3 28.08.2019 16:50
5
Ответы
cherdancev05Gleb
20.08.2020 17:27
#include <iostream>
using namespace std;
int main() {
const int S = 6;
int matrix[S][S];
cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
for (int i = 0; i < S; i++) {
for (int j = 0; j < S; j++) {
cin >> matrix[i][j];
}
cout << endl;
}
int p;
cout << "p = ";
cin >> p;
int count = 0, max;
for (int i = 0; i < S; i++) {
max = matrix[i][0];
for (int j = 1; j < S; j++) {
if (matrix[i][j] > max) max = matrix[i][j];
}
if (max > p) count++;
}
cout << endl << "ответ: " << count;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ДашаШирова
03.09.2020 00:48
Как называется самая минимальная единица измерения информации?...
NeZoX11111111
09.02.2021 21:46
Процедура которая выводит на экран все делители переданного ей числа в одну строчку. ПАСКАЛЬ....
irina18221
09.02.2021 21:46
Вычислите а) 1100110(2) х 1011010(2); б) 2001,6(8) х 125,2(8); в) 2C,4(16) х 12,98(16)....
PavelSahka
09.02.2021 21:47
Что есть в растровом редакторе Gimp, но нет в растровом редакторе Paint?...
Лейла1994
09.02.2021 21:48
Укажи в каком верно определен результат:* 20//6=2 5%2=1 3**2=6...
KatyaKuxar
09.02.2021 21:50
дан интервал времени  часах ,секундах минутах ,напишите программу которая определяет тот же интервал секундах( Phyton)...
Sezim67
22.02.2021 18:04
(в первой ссылке та же таблица дана как и сверху)...
eeeeroock
17.05.2020 10:58
При копировании содержимого ячейки со значением n1 посредством действия автозаполнения в новой ячейке получим результат:Варианты ответа m2n1n2другой вариантm1...
Pashitsyna
17.05.2020 10:58
Запись С$3 устанавливается для:Варианты ответа Относительной ссылкиАбсолютной ссылкиСмешанной ссылки...
KerimovaLuiza919
17.05.2020 10:57
Потрібно написати програму у python, в якій потрібно накопичити суму чисел, що дорівнює РІВНО 100 з випадкових чисел від 1 до 10, якщо сума стає більша за 100, то починаємо...
Популярные вопросы
Велосипедист массой 31 кг движется со скоростью 35 м/с. вычисли...
2
Вэтих 2 простых по сути речевые и лекические ошибки + произношение...
1
Нужно убрать речевые ошибки и недочёты. !...
1
1. найдите словосочетания со страдальными причастиями. определите...
1
Сообщение на тему : моё поведение в школе 10 предложений! ...
2
Напишите сочинение на тему капсула в будущее...
3
Число -7 является корнем уравнения [tex]x^2 - 17x + p = 0[/tex]найдите...
2
Co=(t,ni,he) →x1 →(1500’c) x2 →(t,ni,h2) x1 →(hno3)x4 с цепочкой...
3
(принцип, згідно з яким нуклеотиди в протилежних ланцюгах днк відпові...
1
Задано два числа n і k. знайдіть кількість чисел з діапазону від...
3
using namespace std;
int main() {
const int S = 6;
int matrix[S][S];
cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
for (int i = 0; i < S; i++) {
for (int j = 0; j < S; j++) {
cin >> matrix[i][j];
}
cout << endl;
}
int p;
cout << "p = ";
cin >> p;
int count = 0, max;
for (int i = 0; i < S; i++) {
max = matrix[i][0];
for (int j = 1; j < S; j++) {
if (matrix[i][j] > max) max = matrix[i][j];
}
if (max > p) count++;
}
cout << endl << "ответ: " << count;
return 0;
}