tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Впрограмме имеется список
Впрограмме имеется список имен и соответствующие им буквы и буквы-пароли. пользователь вводит букву имени, если она зарегистрирована, его спрашивают пароль и сообщение о том, соответствует ли последний истине или нет. на языке с++
Ксения26941479
3 14.09.2019 06:40
3
Ответы
Den4ikBLeT
07.10.2020 13:38
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
int n,k,ind;
cout<<"n = "; cin>>n;
string a[n][3];
string inp;
for (int i=0; i<n; i++) {
cout<<"record number: "<<i+1<<endl;
cout<<"name: "; cin>>a[i][0];
cout<<"letter: "; cin>>a[i][1];
cout<<"password: "; cin>>a[i][2];
}
cout<<endl;
cout<<"letter: "; cin>>inp;
k=0;
for (int i=0; i<n; i++)
if (a[i][1]==inp) {
k=1; ind=i;
}
if (k==0) cout<<"no letter "<<inp<<endl;
else {
cout<<"password: "; cin>>inp;
if (inp!=a[ind][2]) cout<<"not valid password"<<endl;
}
system("pause");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
cJKYSIRJH
01.03.2021 17:32
Догадайся, как построена эта числовая последовательность, и ВПиши недостающие числа.1, 3, 4, 6, 7, 9, , , 13......
calusiker
01.03.2021 17:32
ПИТОН. Создайте двумерный массив(список) и при вводе двух целостных чисел(размера списка), массив должен заполниться в виде чередования чисел 1 и 0. Ввод: 5 6 Вывод: 1 0 1 0 1...
Кира3611
01.03.2021 17:33
Составить программу для вычисления функции (паскаль...
nmpepatop1
01.03.2021 17:33
Дано натуральное число N(0≤N≤10^9) Создайте проект нахождения суммы и произведения цифр этого числа .На языке Python(тема:цикл с постусловием .Оператор Repeat-Until)...
EvaTV
24.04.2019 17:00
Для хранения растрового изображения размером 128х128 пикселей отвели 4 кбайт памяти. каково максимально возможное число цветов в палитре изображения?...
alinaharitonovi
24.04.2019 17:00
Рисунок из 256 цветов имеет информационный объем 2400 байтов. из скольких точек он состоит?...
mvrlin
24.04.2019 17:00
Для хранения растрового изображения размером 128х128 пикселей отвели 4 кбайт памяти. каково максимально возможное число цветов в палитре изображения?...
AnitaGo
04.02.2022 08:54
Математическая логика , построить аналитически СКНФ и СДНФ...
jamesa99
04.02.2022 08:55
Предмет МДК 01.02 Нужна с таблицей...
taush
04.02.2022 09:06
я в этом ничего не понимаю):...
Популярные вопросы
Задание. Вставить пропущенные слова. В старинном городе Верона в Италии жили...
2
Во к рассказу сахарный ребёнок 1-3глава (на каждую главу по 2 во с ответом)...
2
Какие признаки отличают организмы растений и животных?...
1
Тема: Діана Вінн Джонс Мандрівний замок Хаула . Образ Софі, світ її мрій, бажань,...
1
Плотность вещества-это физическая величина показывающая Чему равна (равно)...
2
нужны ли здесь запятые???...
3
Как налегает одно перо на другое у птиц? Какое значение имеет такое расположение...
2
Найдите значение выражения 6*5,2-6*4,2-2....
3
За що заарештували Iвана Силу?...
2
Что тут делать нужно и КАК, подскажите...
2
#include <iomanip>
using namespace std;
int main() {
int n,k,ind;
cout<<"n = "; cin>>n;
string a[n][3];
string inp;
for (int i=0; i<n; i++) {
cout<<"record number: "<<i+1<<endl;
cout<<"name: "; cin>>a[i][0];
cout<<"letter: "; cin>>a[i][1];
cout<<"password: "; cin>>a[i][2];
}
cout<<endl;
cout<<"letter: "; cin>>inp;
k=0;
for (int i=0; i<n; i++)
if (a[i][1]==inp) {
k=1; ind=i;
}
if (k==0) cout<<"no letter "<<inp<<endl;
else {
cout<<"password: "; cin>>inp;
if (inp!=a[ind][2]) cout<<"not valid password"<<endl;
}
system("pause");
return 0;
}