Впаскале составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр.

КитиКэт13 КитиКэт13    1   22.06.2019 17:10    1

Ответы
lamsjsj lamsjsj  02.10.2020 08:40
Var
  n, a, b, c, d, s, p: integer;

begin
  Write('Введите натуральное четырехзначное число: ');
  Readln(n);
  if (n > 9999) or (n < 1000) then Writeln('Число должно быть четырехзначным')
  else begin
    a := n div 1000; d := n mod 10; n := (n div 10) mod 100;
    b := n div 10; c := n mod 10;
    s := a + b + c + d;
    p := a * b * c * d;
    Writeln('Сумма цифр равна ', s, ', а их произведение равно ', p)
  end
end.

Тестовое решение:
Введите натуральное четырехзначное число: 2345
Сумма цифр равна 14, а их произведение равно 120
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика