Впаскале. составить программу, по которой компьютер находит произведение нечетных чисел, начиная с единицы, и до тех пор, пока на вопрос, задаваемый после каждого шага вычислений: «продолжить вычисления? (д/н)», отвечают ‘д’.

bkonok832 bkonok832    2   28.06.2019 22:00    7

Ответы
Superklass1111 Superklass1111  02.10.2020 14:41
Var  a:longint;  b:integer;  s:string;  
begin 
 readln(s); 
 a:=1;  b:=1; 
 repeat   
  writeln('Продолжить вычисления? (Д/Н)');   
  b:=b+2;   
  a:=a*b;   
  readln(s); 
 until (s<>'Д'); 
 write(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика