tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Впаскале составить программу
Впаскале составить программу которая для натуральных чисел m и n находит min(2n,m)*nod(2n,3m)
akbotawka02
3 25.08.2019 12:10
5
Ответы
prostooo202003
05.10.2020 18:44
PascalABC.NET 3.x
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Rin1111
02.04.2022 02:36
Между населенными пунктами А, B, C, D, E, F построены дороги. !...
unisens
02.04.2022 02:36
Реферат на тему информатика 6 класс. Объем 10 страниц....
avetisyana902
02.04.2022 02:41
Определите значение переменной после выполнения алгоритма: Алгоритм a:= 8 b:=98 mod a b:=8/b a:=b div 2 + 28...
hdjdjdjsdusjhdjd
09.04.2020 07:55
Сілтемелердің кестесі тобының анықтамасын жазу...
мяв1
30.07.2019 14:50
Заполнить массив с из 20 элементов следующим образом: первые 10 элементов случайные числа из интервала (-15, 21), следующие 7 по формуле i*6, остальные ввести с клавиатуры....
julka19981
12.09.2019 22:10
Записать логическое высказывание, обратное данному: маша блондинка,или её соседка-брюнетка....
dianacat1017
11.09.2019 01:00
Скласти алгоритм обчисленя значеня виразу типу x=a+b-a-b...
Vasulivna123
10.06.2021 14:24
зобразити процеси за пунктами 1 та 2 у вигляді схеми обміну з використанням позхначень сторін обміну А та В вихідного повідомлення та шифротексту позначень процедур шифрування...
VolandDrein
10.06.2021 14:23
Автомобіль подолав відстань s км через населений пункт за t хв. Інформація вводиться в файл Input.txt. Визначити, чи не порушив водій правил дорожнього руху, якщо швидкість...
Iasia198
10.06.2021 14:21
PYTHON. Напишите программу для печати даты и времени на текущий момент в различных форматах как в исходных данных. Используйте модули time и datetime. Входные данные:...
Популярные вопросы
Куда макар телят не гонял составить предложения...
2
46030 дм2 надо перевести в квадратные метры и дециметры...
1
Как переводится can i have some more cake , please ? where s your...
1
Охарактеризувати козака швайку дуже потібно пліз...
1
Надо) напишите уравнение реакции с которых можно осуществить следующие...
2
Використали на 1костюм 4 м використали тканини 36 м кількість костюмов?...
2
Перевод ! 5 класс книга спортлайт 1 как выглядит твоя новая квартира?...
1
Выписать слова с безударными гласными в корне и слова с согласными...
1
Как пишится работа на башкирском языке...
1
Запишіть слова кожної групи за алфавітом. 1. арка, дрова, посуд, трагедія,...
3
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72