tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Впаскале составить программу
Впаскале составить программу для ввода с клавиатуры 7 целых чисел. вывести на экран: 1) элементы массива с положительными значениями. 2)элементы массива с нечетными значениями 3)элементы массива, значения которых положительны и кратны 5
selemenevakrist
3 06.09.2019 21:10
4
Ответы
elizabethniall
06.10.2020 21:51
// PascalABC.NET 3.3, сборка 1541 от 29.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Введите 7 целых чисел:',7);
Write('Положительные: '); a.Where(x->x>0).Println;
Write(' Нечетные: '); a.Where(x->x.IsOdd).Println;
Write('Положительные, кратные 5: '); a.Where(x->(x>0) and (x mod 5=0)).Println
end.
Пример
Введите 7 целых чисел: -5 6 21 15 -20 40 0
Положительные: 6 21 15 40
Нечетные: -5 21 15
Положительные, кратные 5: 15 40
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
WepaDarkSouls
06.06.2020 08:17
Объясните языком, что такое __init__ в python? Заранее за ответ! ...
NarukiTYAN
26.11.2020 15:15
Записать математическое выражение на языке паскаля...
victoriagnyliak
26.11.2020 15:15
Из 30 учащихся класса на уроке присутствуют 24 ученика. Напишите программу, высчитывающую процент посещаемости в этом классе. очень надо, заранее...
annakot3
26.11.2020 15:15
Ребят решить ДКР, у меня 13 вариант. СТОИТ ВОПРОС об отчислении. Очень...
irkorwp0dj0n
21.06.2019 14:00
Маша закодировала 3 слова окно ,тьма, веер.подпиши буквы код их...
bogussasa7
20.02.2021 10:30
определите формулы кислоты,имеющей следующий элементный состав H=3,7% P=37,8% O=58,5% (с подробным решением)...
KaterinaReyn
20.02.2021 10:30
номер 990 математика решите неравенства и изобразите множество их решений на координатной прямой только четные...
Sofa29122005
20.02.2021 10:30
Область значение функции:...
алла330
20.02.2021 10:30
Make sentences using the words given. 1) The claimant, by the other party, for the loss caused, the compensation, got. 2) Receive statements, in the case, in legal memo, from...
maksisenko6451
20.02.2021 10:31
ВЫПОЛНИТЕ УМНОЖЕНИЕ. БУДУ ОЧЕНЬ БЛАГОДАРНА -4x3(x2-а) -5x4(2х-х3) 8q15(q10-q11)...
Популярные вопросы
(2целая1/12-1целая5/6)x=3/4. это уравнение...
3
От данных глаголов в неопределенной форме образовать глаголы во 2-м лице единственного...
2
Отдельная рыбья чешуя каково её значение...
1
Связаны ли между собой опричнина и укоренившееся в прозвище ивана iv...
3
Вкаких словосочетаниях нужно вставить в окончания только букву и? 1) в капельк_...
3
3(6a-1)+7a=8a+7(2a-5)+3 решите уровнение...
3
Гриб трутовик это шляпочный или паразитический гриб?...
3
Write the correct prepositions. i always go turkey for my holidays. ann lives...
1
Какая птица зимой вьет гнездо и выводит птенцов?...
2
12. решите : за три дня в колхозе вспахали 250 га. площадь, вспаханная в первый...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Введите 7 целых чисел:',7);
Write('Положительные: '); a.Where(x->x>0).Println;
Write(' Нечетные: '); a.Where(x->x.IsOdd).Println;
Write('Положительные, кратные 5: '); a.Where(x->(x>0) and (x mod 5=0)).Println
end.
Пример
Введите 7 целых чисел: -5 6 21 15 -20 40 0
Положительные: 6 21 15 40
Нечетные: -5 21 15
Положительные, кратные 5: 15 40