Впаскале: 1) составить список переменных с указанием типов данных для программы, вычисления среднего роста студентов в группе. 2) составить программу вычисления надбавки к зарплате в зависимости от стажа работы: до 10 лет надбавка равна 10%, далее за каждый год добавляется 2%.

kseshkaShkolnikova kseshkaShkolnikova    2   18.08.2019 08:00    8

Ответы
ОлегВолгин228 ОлегВолгин228  05.10.2020 02:30
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.


program q2;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of real;
Summ:real; // переменная для хранения суммы чисел
MNum:real; // переменная для хранения среднего арифметического
BEGIN
{создание последовательности n отрицательных вещественных чисел}
Writeln('Случайные отрицательные вещественные числа: ');
for i:=1 to n do
begin
mass[ i ]:=((random(9)+1)+(random(9)+1)/10)*(-1); //присваеваем переменной случайное вещественное от 1 до 10
write(mass[ i ],'; '); //выводим
end;
{Вычисление среднего арифметического}
for i:=1 to n do
Summ:=Summ+mass[ i ]; // высчитываем произведение
MNum:=Summ/n;

{Вывод результатов}
writeln;
writeln('Среднее арифметическое: ',MNum);
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика