Впаскаль абс. в эвм поступают результаты соревнований по плаванию для трех спортсменов. составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.

vk2931416haker vk2931416haker    1   19.05.2019 10:20    15

Ответы
Ариана20021111 Ариана20021111  12.06.2020 14:26

var i :integer;

     a, b:real;

begin

for i:=1 to 3 do

     begin

       write ('a=');

       readln(a);

      if (a>b) then b:=a;

     end;

writeln ('a=' , b);

end.

 

ПОКАЗАТЬ ОТВЕТЫ
RasDua RasDua  12.06.2020 14:26

const
N = 3;

var
a: array[1..N] of integer;
i, max: integer;

begin
max := 0;
writeln('Введите результаты трех спортсменов');
for i := 1 to N do readln(a[i]);
for i := 1 to N do
begin
if a[i] > max then
max := a[i];
end;
writeln;
writeln('Лучший результат среди трех спортсменов - ', max);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика