Вpascal №4. дана величина a, выражающая объем информации в мегабайтах. составьте программу перевода величины а в более мелкие единицы информации. №5. даны длины сторон треугольника a, b, c. найти площадь треугольника s. составьте программу решения поставленной . , где р – полупериметр №6. для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c).

Ритка121 Ритка121    3   27.07.2019 01:10    3

Ответы
ArhangelTYT ArhangelTYT  07.09.2020 21:00
4.
var
a:real;
begin
write('Введите количество мегабайт=');read(a);
writeln('Количество килобайт=',a*1024);
writeln('Количество байт=',a*1024*1024);
writeln('Количество бит=',a*1024*1024*8);
end.

5.
var
a,b,c,p,S:real;
begin
write('Введите сторону a=');read(a);
write('Введите сторону b=');read(b);
write('Введите сторону c=');read(c);
P:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
write('S=',s:5:2);
end.

6.
var
a:integer;
begin
write('Введите количество суток=');read(a);
writeln(24*a,' ','часов');
writeln(60*24*a,' ','минут');
writeln(60*60*24*a,' ','секунд');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика