Вот условия задачи: составить программу расчёта значения функции

Z=(x-2*ctg*2y)/{8x-5 arctg y}

вот код

program tri;

var x,y,z:real;

begin

writeln('Введите x, Введите y');

read(x,y);

z:=(x-2*cos(x)/sin(x)*2*y)/{8*x-5*arctan(1/x)*y}

writeln('При x = ', x , ' y = ', y, ' z = ', z:6:2 );

readln(x,y);

end.

Пишет ошибку Program1.pas(7) : Ожидалась функция, встречена процедура Writeln
ПАСКАЛЬ

romab07 romab07    3   26.05.2021 03:58    2

Ответы
senyaavdeev07 senyaavdeev07  26.05.2021 06:00

Объяснение:

z:=(x-2*cos(x)/sin(x)*2*y)/{8*x-5*arctan(1/x)*y}

6-ю строчку переделать.

Вот так должно быть :

z:=(x-2*cos(x)/sin(x)*2*y)/(8*x-5*arctan(1/x)*y);

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика