Вопрос по информатике напишите программы в pascale для такой 1.петя впервые пришел на урок физкультуры в новой школе. перед началом урока ученики выстраиваются по росту, в порядке невозрастания. напишите программу, которая определит, на какое место в шеренге пете нужно встать, чтобы не нарушить традицию, если заранее известен рост каждого ученика и эти данные уже расположены по невозрастанию (то есть каждое следующее число не больше предыдущего). если в классе есть несколько учеников с таким же ростом, как у пети, то программа должна расположить его после них. сначала задано число n учеников. потом введены росты учеников в количестве n (росты не превышают 200). затем, на новой строке, вводится рост самого пети. программа должна вывести единственное число — номер пети в шеренге учеников

nabiulinadasha nabiulinadasha    1   31.07.2019 17:40    4

Ответы
CoolGirl78 CoolGirl78  03.10.2020 18:50
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger();
  var a:array of integer;
  a:=ReadArrInteger(n);
  var p:=ReadInteger();
  Sort(a);
  var i:=n-1;
  while a[i]>p do Dec(i);
  Writeln(i+2);
end.

Тестовое решение:
5
175 169 172 180 174
174
4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика