Водномерном массиве а(к) хранятся результаты социологического опроса, напишите программу для подсчета кол-ва результатов отклоняющихся от среднего не более чем на 7% кол-во людей: 200. [0; 100]случайные числа( которые ставят люди). программа должна быть написанна для visual basic.

Камалия11 Камалия11    1   17.05.2019 22:50    2

Ответы
125894 125894  11.06.2020 04:05

using System;
using System.Linq;

namespace Interesting {
    class Program {
        static void Main(params int[] a) {
            int n = 0;
            foreach (int i in a) {
                n += (Math.Abs(i - a.Average()) / 100 <= 0.07) ? 1 : 0;
            }
            Console.WriteLine(n);
        }
    }
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика