tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Водномерном массиве а(10)
Водномерном массиве а(10) вычислить среднее арифметическое положительных элементов
yalex83p0a2c7
3 03.06.2019 02:10
4
Ответы
самаучка003
03.07.2020 15:37
Var
a:array[1..1000000]of integer;
b,i,n,c,k:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if a[i]>0 then begin
c:=c+a[i];
k:=k+1;
end;
write(c/k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
danayakim
25.11.2020 18:34
За ответ от Можете написать код для программы С++, для этого задания? Что бы в конце работала программа по данному заданию. Написать программу в C++, которая формирует двумерную...
ElzaraLeonovich
25.11.2020 18:34
Чему будет равна величина b после выполнения фрагмента программы? val( 48 ,b,er); (ввести только ответ. например: слово или число) *...
Айла2010
25.11.2020 18:34
Чому буде равна величина А после выполнения фрагмента программы?A:= математика ;Delete(a,3,2);Delete(a,5,4);(ввести только ответ. например: слово ) * ...
Amy1503
04.12.2020 15:57
Задача о пути торможения автомобиля дана на языке Паскаль, как ее записать, используя Питон?...
rsharapov
04.12.2020 15:57
Дан массив Т1…T13. Посчитать количество отрицательных элементов массива с четными индексами (n). Если n 7 все элементы с нечетными индексамиувеличить на 10, иначе все элементы...
valeria15queen
04.12.2020 15:57
Задача 9 Напишите НАИБОЛЬШЕЕ число х, для которого ЛОЖНО высказывание: НЕ(x =50) ИЛИ НЕ(x = 20)...
rudolf2006
04.12.2020 15:57
решите,информатичка убьет))...
anonim197
28.05.2019 03:20
Для записи текста использовался 64-символьный алфавит.какой объем информации в байтах содержат 10 страниц текста,если на каждой странице расположено 32 строки по 64 символа...
Psix73
28.05.2019 03:20
Как называется элементарное действие, из которых состоит каждая машинная команда?...
MisterStickman1
21.04.2020 15:48
1.Які елементи стилю можна змінювати(можна вибрати декілька варіантів)А) Відступи та інтервалиБ) Орієнтацію сторінкиВ) Вирівнювання абзацуГ) Розмір і вид шрифту2.Що можна...
Популярные вопросы
Анализ стихотворения «зима недаром злится» 1.приемы,2.сравнения,3.роль...
1
Надо васс мегаа write the sentence using have (has) been to/have (has)...
2
Измученный жизнью суровой, не раз я себе находил. в глаголах предвечного....
1
Исправьте грамматические ошибки,связанные с неправильным построением словосочетаний1)...
2
Складiть речення за схемами [ ] ; проте [ ] [ ] , i [ ]...
2
Представьте число 24 дробь 9 75-тых в виде десятичной дроби....
1
При каких значениях х равны значения многочленов (1-3x)(x+1) и (x-1)(x+1)...
2
Природа состоит из множества различных тел любой предмед из окоужающего...
2
Надо найти угол 5 в параллелограмме abcd если угол 1 = углу 2 и угол 3=...
3
Два словосочетания.. в маленьком амбаре держат сто...
2
a:array[1..1000000]of integer;
b,i,n,c,k:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if a[i]>0 then begin
c:=c+a[i];
k:=k+1;
end;
write(c/k);
end.