tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вмассиве в(11) все элементы
Вмассиве в(11) все элементы из интервала (a,b) занесите в массив с и найдите сумму элементов полученного массива в с++. 30 .
Dodgesantafe
3 30.09.2019 23:40
3
Ответы
Голубь20079
27.08.2020 10:28
Т.к. a и b были не заданы, взял с 0 по size.
#include <iostream> #include <array> #include <algorithm> #include <numeric> constexpr std::size_t SIZE = 11u; int main() { std::array<int, SIZE> b{ -3, -2, -1, 0, 1, 2, 3, 4, 5, 6, 7 }; std::array<int, SIZE> c; std::transform(b.begin(), b.end(), c.begin(), [](int const& x) { return x; }); std::cout << std::accumulate(c.begin(), c.end(), 0); }
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Nazym99
01.07.2019 18:30
Дан целочисленный линейный массив. удалить из него последний четный элемент....
zhanelkenesbekova
18.05.2020 13:05
A. Какую задачу решает данная программаb. Определите количество переменных c. Определите имена переменных d. Найдите ошибку в программе информатика 6-5 класс Сор...
настя6798
18.05.2020 13:03
Какое расширение имеют файлы...
LeraSmile12
18.05.2020 13:01
Берілген тұжырымдамалардың ақиқат немесе жалған екенін анықтаңыз ( ) Иә Жоқ Блок-сызба - алгоритмді жазудың графиктік тәсілі Адам, компьютер, автомат – алгоритм орындаушысы...
Вайсбергггг
18.05.2020 13:01
Составить программу.Определите количество отрицательных элементов в целочисленном массиве длины 30 (массив заполняется с клавиатуры)....
Остап1843
18.05.2020 13:01
Запишите выражение с функции ЭТА) А5+А6+А7+В5+В6+В7Б) (С4+С5+С6+С7) /4 (СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ)...
Arisha224
18.05.2020 12:59
На С# 1. Задать (ввести с клавиатуры) целочисленный массив A из n элементов. Выяснить, число положительных элементов. 2. Создать одномерный массив X из 10 элементов случайным...
абдулоахмед1
18.05.2020 12:58
Всі формули для обчислення значень числових виразів у Excel...
aidosashimbek200
18.05.2020 12:57
Берілген тұжырымдамалардың ақиқат немесе жалған екенін анықтаңыз ( ) Иә Жоқ Блок-сызба - алгоритмді жазудың графиктік тәсілі Адам, компьютер, автомат – алгоритм орындаушысы...
cheburek20
18.05.2020 12:57
1.Что такое мультимедиа? Каковы основные составляющие мультимедиа? 2.Что такое компьютерная презентация? 3.Каковы основные этапы создания презентаций? 4.Вычислите, сколько килобайтов...
Популярные вопросы
Нужна .x/(x+3)+(4x+6)/(x^2+4x+3)=0 (полное решение)...
2
Сочинение почему книгу называют источником знаний...
3
Решить пример с выражений 7 + 15 а при а равно 3...
2
Составить предложения с группами синонимов глядит-смотрит выручает дремлет-спит...
1
Длина полоски равна 1 дм.сколько сантиметров составляет половина полоски?...
2
Текст на тему транспорт будущего(6-8 предложений)...
1
Среди дробей 5,6 5,8 3,10 7,16 9,24 11,18 8,28 10,12 10,3 5,4 13,36 1,14...
1
Напишите 2 синквейна 1 про грибы а второй про биологию...
2
Напишите положительные стороны отрицательные стороны...
2
Какие типы предложения есть по цели высказывания?...
2
Т.к. a и b были не заданы, взял с 0 по size.
#include <iostream> #include <array> #include <algorithm> #include <numeric> constexpr std::size_t SIZE = 11u; int main() { std::array<int, SIZE> b{ -3, -2, -1, 0, 1, 2, 3, 4, 5, 6, 7 }; std::array<int, SIZE> c; std::transform(b.begin(), b.end(), c.begin(), [](int const& x) { return x; }); std::cout << std::accumulate(c.begin(), c.end(), 0); }