Вмассиве хранится информация о средней цене продуктов за месяц. составить программу, которая подсчитывает сколько продуктов стоили дороже 150 руб. элементов в массиве-15, диапазон цен- от 0 да 200руб. на экран вывести все элементы массива и элементы удоволетворяющие нашему условию. напиши полностью программу)

timon201 timon201    1   13.09.2019 00:30    6

Ответы
танюша237 танюша237  07.10.2020 10:46
Const n=15; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив Цены');
for i:=1 to n do
 begin
 a[i]:=random(201);
 write(a[i]:4);
 end;
writeln;
k:=0;
writeln('Дороже 150 руб:');
for i:=1 to n do
 if a[i]>150 then begin write(a[i]:4); k:=k+1; end;
writeln;
writeln('k = ',k);
end.

Пример:
Цены:
136 16 50 45 62 41 163 149 175 35 14 51 110 156 175
Дороже 150 руб:
163 175 156 175
k = 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика